Compatibilidade de Certificados

Última atualização: | Ver Documentação completa

A Let’s Encrypt almeja ser compatível com a maior quantidade de softwares possível sem comprometer a segurança. O principal fator que determina se uma plataforma pode validar os certificados da Let’s Encrypt é se esta plataforma inclui o certificado IdenTrust’s DST Root X3 e sua trust store. Um fator secundário é se a plataforma suporta os certificados modernos SHA-2 (Inglês), devido a todos os certificados da Let’s Encrypt usarem SHA-2.

Se o seu certificado é validado em alguma das plataformas “Sabidamente Compatíveis” mas não em outras, o problema pode ser uma configuração incorreta do servidor web. Se você está tendo problemas com plataformas modernas, a causa mais comum é falha ao prover a cadeia de certificados. Se você está tendo problemas em plataformas antigas como Windows XP, as causas mais comuns são falha na configuração de uma suíte de cifras, versão TLS suportada pela plataforma ou que a plataforma não tem suporte a Server Name Indication (SNI). Teste o seu site com Servidor de Testes da SSL Labs (Inglês). Se isto não identificar o problema, peça ajuda nos nossos Fóruns da Comunidade.

Talvez seja interessante visitar esta thread em particular no fórum da comunidade (Inglês) para mais informações sobre compatibilidade.

Sabidamente Compatíveis

Sabidamente Incompatíveis