Совместимость сертификатов

Последнее обновление: | Вся документация

Let’s Encrypt стремится обеспечить совместимость с максимально возможным количеством приложений не в ущерб безопасности. Основным фактором, определяющим, может ли платформа использовать сертификаты Let’s Encrypt, является наличие сертификата IdenTrust’s DST Root X3 в ее доверенном хранилище. Второй фактор – поддержка платформой современных сертификатов SHA-2, так как все сертификаты Let’s Encrypt используют SHA-2.

Если ваш сертификат работает лишь на некоторых платформах из списка “Известные совместимые платформы”, но не на всех, проблема может быть в неправильных настройках сервера. Если у вас проблема с современными платформами, наиболее частая причина – непредоставление правильной цепочки сертификатов. Если проблема возникает со старыми платформами, такими как Windows XP, возможная причина – ошибка конфигурации ciphersuite, или версия TLS, которая поддерживается на платформе, или платформе не хватает поддержки Server Name Indication (SNI). Протестируйте ваш сайт с помощью SSL Labs’ Server Test. Если это не поможет определить проблему, обратитесь за помощью на Форумы сообщества.

Возможно, это обсуждение на форумах сообщества поможет вам узнать больше о совместимости.

Известные совместимые платформы

Известные несовместимые платформы