Mises à jour du protocol ACME

Dernière mise à jour : | Voir toute la documentation

Le protocole ACME standardisé à l’IETF, RFC 8555, est la pierre angulaire de la manière dont Let’s Encrypt fonctionne.

Points d’entré de l’API

Nous avons actuellement les points d’entré d’API suivants. Veuillez consulter notre documentation sur les divergences pour comparer leur implémentation aux spécifications ACME.

ACME v2 (RFC 8555)

ACME v1 (obsolète)

Nouvelles fonctionnalités ACME rétro-compatibles

De temps en temps, Let’s Encrypt peut implémenter de nouvelles fonctionnalités compatibles avec les versions antérieures des API existantes. Généralement, de nouvelles fonctionnalités rétrocompatibles sont introduites car nous avons décidé d’implémenter une partie de la spécification ACME que nous n’avions pas implémentée auparavant.

Lorsque de nouvelles fonctionnalités seront introduites dans les API existantes, les fonctionnalités seront toujours clairement spécifiées dans une spécification publique ACME et ne casseront pas les clients correctement implémentés.

Nouvelles versions d’ACME avec des changements non rétro-compatibles

Nous n’avons pas l’intention de modifier notre support ACME, mais si nous pensons qu’il est important de le faire, nous nous efforcerons de permettre une transition en douceur au fil du temps et de communiquer aussi à l’avance que possible. Les administrateurs système devraient maintenir la possibilité de déployer des mises à jour de leurs clients ACME si un changement est nécessaire.